Jump to content

Wahoo Kickr Owners


awesme
 Share

Recommended Posts

  • Replies 472
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

So with all the ERG issues.....anyone know how to solve the problem or what?

Assuming you are using Ant+ with a USB dongle...

 

I place the dongle as close to the rear of the Kickr as possible - either just behind or hang it off my rear brake caliper using a USB extension cable - this solved a lot of the drop issues I was having at the time

Link to comment
Share on other sites

Are you running in ANT or Bluetooth mode. After my Garmin HRM failed, i have a Tickr now and the whole system runs off Bluetooth without issues. I have wirelsss mouse, but the rest is hardwired for my setup. Not had any drops for a long time. Running Kickr 4 on Rouvy.

Link to comment
Share on other sites

Are you running in ANT or Bluetooth mode. After my Garmin HRM failed, i have a Tickr now and the whole system runs off Bluetooth without issues. I have wirelsss mouse, but the rest is hardwired for my setup. Not had any drops for a long time. Running Kickr 4 on Rouvy.

ANT+ only. I understand that your Companion App can act as a BT bridge between your trainer and the software? 

Link to comment
Share on other sites

  • 2 months later...

Hi guys,

Wondering if anyone has any advice before I contact the guys at iKhambi...

 

Kickr 3 & almost done 10 000KM on it.

 

Was on a Zwift free ride this morning when all of a sudden the power went all over the place. Hardly had to turn the pedals and I was seeing a huge amount of power- so much so that I got all the Power Badges in Zwift unintentionally.

 

I stopped my ride and tried to un-pair the sensors from Zwift and repair - no luck.

Quit the ride, exited Zwift, unplugged the unit, plugged it in again and tried to do a spindown - spindown failed. I tried to redo the spindown but no luck.

 

I'm wondering if the unit is kaput??

Link to comment
Share on other sites

Hi guys,

Wondering if anyone has any advice before I contact the guys at iKhambi...

 

Kickr 3 & almost done 10 000KM on it.

 

Was on a Zwift free ride this morning when all of a sudden the power went all over the place. Hardly had to turn the pedals and I was seeing a huge amount of power- so much so that I got all the Power Badges in Zwift unintentionally.

 

I stopped my ride and tried to un-pair the sensors from Zwift and repair - no luck.

Quit the ride, exited Zwift, unplugged the unit, plugged it in again and tried to do a spindown - spindown failed. I tried to redo the spindown but no luck.

 

I'm wondering if the unit is kaput??

I had the exact same issue,my power meter had moisture inside, this caused the unit to bug out. removed power meter and it was sorted

Link to comment
Share on other sites

I had the exact same issue,my power meter had moisture inside, this caused the unit to bug out. removed power meter and it was sorted

Thanks for the reply... Power meter inside the Kickr?

Link to comment
Share on other sites

Hi guys,

Wondering if anyone has any advice before I contact the guys at iKhambi...

 

Kickr 3 & almost done 10 000KM on it.

 

Was on a Zwift free ride this morning when all of a sudden the power went all over the place. Hardly had to turn the pedals and I was seeing a huge amount of power- so much so that I got all the Power Badges in Zwift unintentionally.

 

I stopped my ride and tried to un-pair the sensors from Zwift and repair - no luck.

Quit the ride, exited Zwift, unplugged the unit, plugged it in again and tried to do a spindown - spindown failed. I tried to redo the spindown but no luck.

 

I'm wondering if the unit is kaput??

Overheating sensor .Get a fan on the unit 

Link to comment
Share on other sites

Overheating sensor .Get a fan on the unit 

I thought about that but was averaging 165 watts for 40km's.... I've gone much harder and longer than that with no issues.

Link to comment
Share on other sites

Just got back from the guys at Ikhambi...

 

I'm totally amazed at their customer service - I'm a Wahooligan for life as a result of this!

 

So this was the culprit of my issue experienced yesterday - faulty motherboard.

For those of you interested here's a pic of where the BT/ANT+ chip is located - perhaps it'll help with those of you who are experiencing dropouts.

 

post-83519-0-70774900-1620651150_thumb.jpg

Link to comment
Share on other sites

  • 2 weeks later...

Good morning all, I am sure it has been asked before, My Kickr disconnects from Zwift the whole time, any suggestions, I am going to try a USB extension tonight to get the Dongle closer to the Kickr, anything else that I should look for?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

My Profile My Forum Content My Followed Content Forum Settings Ad Messages My Ads My Favourites My Saved Alerts My Pay Deals Settings Help Logout