Jump to content

Derailer problems


Bateleur1
 Share

Recommended Posts

I have a problem with my front derailer lately.  It seems to get stuck easily with the nasty effect that it would not drop to the small ring when the cable relaxes.  I am not sure if you should lubricate it on a regular basis.  Is it time to replace it or is there any specific lubricant that I should use.  Personaly I think it is time to replace it but would like to hear some opinions.

Link to comment
Share on other sites

You didnt perhaps adjust the two screws on top? Clean it, replace the cable or just check for visible damage. There's not much that can go wrong with the der. Hopefully the problem isnt in your sti...

Link to comment
Share on other sites

Not the STI.  The cable relaxes but the derailer is not dropping back.  At the moment I lubricate it but within days it becomes a problem.  While I ride I unhook my right foot and give it n slight notch then it drops back.  Irretating!

Link to comment
Share on other sites

Give it a good clean with soapy water...and dont lubricate it!! Take it off and check the tension on the spring.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

My Profile My Forum Content My Followed Content Forum Settings Ad Messages My Ads My Favourites My Saved Alerts My Pay Deals Settings Help Logout