Jump to content

Tacx Flux - Broken - Need Help!


The_Phoenix
 Share

Recommended Posts

Hi,

 

Having trouble with a broken Tacx Flux. Bought secondhand on bikehub, and it broke 5 rides in. No use crying over spilt milk. Would like to get it fixed now.

 

The problem is:

 

- red/green light flickers (no power?? belt issue???)

- orange light flickers, do an update, returns to red/green issue

- connects to phone and shows, but no power, no calibration (no data transfer??)

- also no connectivity to macbook for zwifting purposes.

 

I already emailed garmin, who seems to be Tacx agents in SA, but to no avail.

 

Does anyone have any ideas or advice on the way forward, other than to just buy a Kickr  :whistling:

Link to comment
Share on other sites

Hi,

 

Having trouble with a broken Tacx Flux. Bought secondhand on bikehub, and it broke 5 rides in. No use crying over spilt milk. Would like to get it fixed now.

 

The problem is:

 

- red/green light flickers (no power?? belt issue???)

- orange light flickers, do an update, returns to red/green issue

- connects to phone and shows, but no power, no calibration (no data transfer??)

- also no connectivity to macbook for zwifting purposes.

 

I already emailed garmin, who seems to be Tacx agents in SA, but to no avail.

 

Does anyone have any ideas or advice on the way forward, other than to just buy a Kickr  :whistling:

 

Have you tried searching on Youtube. The original Flux seems to have had a few issues and fixes are well documented.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

My Profile My Forum Content My Followed Content Forum Settings Ad Messages My Ads My Favourites My Saved Alerts My Pay Deals Settings Help Logout