Jump to content

Edge 520 + iphone combo


rickus.jooste
 Share

Recommended Posts

Hi, 

 

I have an Edge 520 paired with an iphone 12 mini. 

 

During my rides the edge just randomly's disconnects from the phone and then reconnects. 

The livetrack never works, maybe 5 mins or so and then nothing. 

 

Does anybody else have this same combo of devices and issues ? 

 

I can't find anything on garmin forums really, some people have the same issue but no real solution from garmin is forthcomming. 

 

I dug and EDGE 25 out of the closet this morning. Livetrack worked perfectly. 

 

 

Link to comment
Share on other sites

Probably a software issue with the 520. Just wait for the next update or try to go back to the previous version and test.

Link to comment
Share on other sites

I gave up on my Garmin 945 with the iPhone, it just never worked. Reboot, reinstall, repeat whatever. The 5 minutes of hope with each firmware update that turns into disappointment..

 

Since I switched to a Samsung S21 it's been perfect all the time.

Edited by Showtime
Link to comment
Share on other sites

I've got a 520 paired with my iPhone 8, both on latest SW versions. Livetrack works as promised, starts automatically and for 99% of rides stays connected the whole ride, although now and again on a MTB ride it does disconnect if we go through areas with poor mobile signal.

 

In December I got taken out by a taxi and the Garmin/iPhone combination informed my emergency contacts perfectly even though I was unconscious at the time. Grateful for that!

 

It wasn't always like this - a couple of versions back of Garmin SW I found Livetrack unusable unless I manually started it for each ride.

Link to comment
Share on other sites

Yo, that is a proper good advertisment for garmin and the incident detection. 

 

I found a random article somewhere on the internet that says the garmin edge has a weird way of handling the storage system. If your storage space reaches it's capacity by way of all the activities and course etc that you accumulate , it frees up space on the fly. This causes some issues appartnley and manifest itself in weird ways. 

 

so i formatted the garmin in windows, FAT fily system with GARMIN as the device label. 

Initial testing has some promising results...

 

This sort-of-solution has no explanation for the android / garmin combo though.

 

Anyway...worth a try if you are frustrated and confused like i am. 

I've got a 520 paired with my iPhone 8, both on latest SW versions. Livetrack works as promised, starts automatically and for 99% of rides stays connected the whole ride, although now and again on a MTB ride it does disconnect if we go through areas with poor mobile signal.

 

In December I got taken out by a taxi and the Garmin/iPhone combination informed my emergency contacts perfectly even though I was unconscious at the time. Grateful for that!

 

It wasn't always like this - a couple of versions back of Garmin SW I found Livetrack unusable unless I manually started it for each ride.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

My Profile My Forum Content My Followed Content Forum Settings Ad Messages My Ads My Favourites My Saved Alerts My Pay Deals Settings Help Logout