Jump to content

KMC 11 speed missing link cant connect!!!


nero123
 Share

Recommended Posts

Hi Guys,

 

I'm hoping for some advice. I bought an 11 speed kmc missing link for my super record chain but can't get the link to lock!! The 10 Speed link was easy to lock in a 10 speed chain but this 11 speed one, just doesn't want to lock? I see on the back of the package it says I need special pliers to open and close the chain but this wasn't necessary with the 10 speed link?

 

Any advice?

Link to comment
Share on other sites

If you are sure that the two post have engaged with the slots in the opposite sides, a bit of tension in the chain with the link in the position between sprocket and chainring in the tension cycle, should do the trick.

 

To make a long story short, if you require a special tool to disengage the link, it is a use-once link only since such tools damage the link.

 

 

 

Get the half-installed link on top and push on the pedals. It will go in.

Link to comment
Share on other sites

For future cleaning of ur chain don't go buy kmc 11 speed links. It work perfect with sram 10spd link

Link to comment
Share on other sites

It's impressive to see Johan Bornman is now available for tech questions even in the middle of the night!

Link to comment
Share on other sites

It's impressive to see Johan Bornman is now available for tech questions even in the middle of the night!

 

 

Ja, we thought long and hard how to beat the bike shops at service and came up with the concept of Applied Insomnia.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

My Profile My Forum Content My Followed Content Forum Settings Ad Messages My Ads My Favourites My Saved Alerts My Pay Deals Settings Help Logout