Jump to content

GPS watch accuracy bug


Chris_
 Share

Recommended Posts

My wife noticed this on her Fenix 6, my 6X however is fine so this is an intermittent event/bug.

 

Some watches (various models from Garmin, Suunto, Polar) are struggling to accurately map GPS data after an activity. It's because of a file on your watch which is failing to update.

 

The fix sounds easy - start an activity, set your watch aside, let it run for an hour, discard the activity. And hopefully the watch finds and updates the file in that time.

 

DC Rainmaker article explains it all better than me...

 

https://www.dcrainmaker.com/2021/01/gps-accuracy-impacting-devices.html/amp?fbclid=IwAR1t72hqIZCvcowQwFLar7A5-ba_ANkzVkbhb8f8iz1b7v-0CfxwFlrXf4M

Link to comment
Share on other sites

Thanks, I have this on my Garmin Fenix 3 as well where it does not correlate with distance on treadmill or a ride on Strava, will give it a try.

Link to comment
Share on other sites

Dankie Chris

 

As of 1 January the Vivoactive 4 has a glitch mapping walks (probably rides as well)

 

The start is about 300m West of my actual position, the whole ride is offset by the same .... so the route has the correct "pattern" ... but passing through houses and shops ...

 

 

Garmin website says they know about this, and are working on a solution ...

 

 

 

PS . The Edge 520 is still working accurately ...

 

 

Edit ... the rout layout is shown to the side, but the distance and speed is still accurate

Edited by ChrisF
Link to comment
Share on other sites

Yep on my polar vantage watch I had a incorrect reading yesterday afternoon for the first km of a 7 km walk.

The 1st 500m were totally screwed and it took about 300m of real distance to register 1 km on the watch... even standing still the meters kept increasing. If I look at the map it is way off course for the first 500m.

 

My wife’s watch a polar M was working normal.

 

Never seen something like it before, good to know what the probable cause was.

Link to comment
Share on other sites

Yep on my polar vantage watch I had a incorrect reading yesterday afternoon for the first km of a 7 km walk.

The 1st 500m were totally screwed and it took about 300m of real distance to register 1 km on the watch... even standing still the meters kept increasing. If I look at the map it is way off course for the first 500m.

 

My wife’s watch a polar M was working normal.

 

Never seen something like it before, good to know what the probable cause was.

 

You can check:  Settings > General Settings > About your watch and scroll down.  It shows when the A-GPS file expire.

 

Mine shows 15/01/2021, hence it was updated on the 1st of Jan.

Link to comment
Share on other sites

Yep on my polar vantage watch I had a incorrect reading yesterday afternoon for the first km of a 7 km walk.

The 1st 500m were totally screwed and it took about 300m of real distance to register 1 km on the watch... even standing still the meters kept increasing. If I look at the map it is way off course for the first 500m.

 

My wife’s watch a polar M was working normal.

 

Never seen something like it before, good to know what the probable cause was.

Getting interesting ....

 

Thought it was just a few Garmin watches. As I said, working fine on the Garmin cycling computer ....

 

 

Will get my old Polar watch out the drawer and give it a try ....

Link to comment
Share on other sites

Garmin Forerunner 935 is working correctly.

 

So it seems a software issue with a few units only

Link to comment
Share on other sites

You can check:  Settings > General Settings > About your watch and scroll down.  It shows when the A-GPS file expire.

 

Mine shows 15/01/2021, hence it was updated on the 1st of Jan.

Mine also shows 15/01/2021, but I did synch and charge my watch after the walk with the errors.

Link to comment
Share on other sites

Mine also shows 15/01/2021, but I did synch and charge my watch after the walk with the errors.

Same.

 

Synced from the watch, also synced with a cable to the PC ...

 

Later found the note on the Garmin site .... seems an issue on the latest sync file ....

 

Will watck my friend's logs ... would be interesting to see if the FR goes funny after an update ....

Link to comment
Share on other sites

Not sure if a longer "soak period", or yet another sync did the trick .... either way, this afternoons walk is again perfect.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

My Profile My Forum Content My Followed Content Forum Settings Ad Messages My Ads My Favourites My Saved Alerts My Pay Deals Settings Help Logout